Skip to content

Error 'X-Content-Type: nosniff' is given since domoticz in beta mode #5

Description

@fennec622

Hi
first thanks for your job
I use personal version of monitor
and since i pass in domoticz beta, monitor doesn't work

[Error] Did not load script at 'http://10.0.0.1:8080/json.htm?type=devices&plan=1&jsoncallback=jQuery31108805318969018416_1521367357609&_=1521367358460' because non script MIME types are not allowed when 'X-Content-Type: nosniff' is given.

When i write

http://10.0.0.1:8080/json.htm?type=devices&plan=1&jsoncallback=jQuery31108805318969018416_1521367357609&_=1521367358460

directly in browser all is ok

I use monitor with apache2

Since 5 days github of domoticz change

request_handler.cpp add
//browser support to prevent XSS
reply::add_header(&rep, "X-Content-Type-Options", "nosniff");
reply::add_header(&rep, "X-XSS-Protection", "1; mode=block");

Can you help me

i thinks must add script type text/json from all request

Thanks

Activity

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Metadata

Metadata

Assignees

No one assigned

    Labels

    No labels
    No labels

    Projects

    No projects

      Milestone

      No milestone

      Relationships

      None yet

      Development

      No branches or pull requests

      Issue actions